Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
  
Packetverluste
09.10.2019, 14:57,
 
Packetverluste
Hallo,

seit ca 1 Woche bemerke ich Packetverluste bei Verbindungen auf externe Server. Mir ist das Problem aufgrund von "hängen" von SSH Sessions aufgefallen.

ein Ping über 1 min (ping -c60 ...) nach Servern wie z.B. google.com, heise.de, amazon.de usw zeigt Packetverluste bis zu 10 %. Ist jemanden dieses Problem schon aufgefallen? Meinen Router habe ich natürlich neu gestartet

z.B.
64 bytes from par10s38-in-x0e.1e100.net (2a00:1450:4007:805::200e): icmp_seq=60 ttl=53 time=15.9 ms

--- google.com ping statistics ---
60 packets transmitted, 58 received, 3,33333% packet loss, time 59113ms
rtt min/avg/max/mdev = 14.859/15.907/17.407/0.744 ms


Viele Grüße,
PoWo
 Quote
09.10.2019, 16:39,
 
RE: Packetverluste
Hallo PoWo.
Das kann ich nicht nachvollziehen.
Habe gerade unter Windows jeweils:
ping heise.de -n 300 -4
und
ping heise.de -n 300 -6

zu den drei von dir genannten URLs ausgeführt.
Außer das amazon.de kein AAAA Record hat, war mein Ergebnis immer:
Ping-Statistik für $IP:
Pakete: Gesendet = 300, Empfangen = 300, Verloren = 0
(0% Verlust),


Kreis Borken. Bornet Ausbaugebiet. Genexis HRG1054 im Bridgemode.
Gebiet aufgeschaltet: 4.Quartal 2014
 Quote
17.12.2019, 21:11, Dieser Beitrag wurde zuletzt bearbeitet: 17.12.2019, 21:12 von launacorp.
 
RE: Packetverluste
Also ich kann grade nur feststellen, dass DNS-Anfragen ewig lange brauchen um beantwortet zu werden.

Hatte mich seit Sonntag 15.02.2019 schon gewundert, warum viele Seiten so "rumspacken".
Habe dann mal meinen PiHole in Verdacht gehabt. Das schien mir allerdings auch seltsam, da ich PiHole schon seit ewigkeiten im Einsatz habe und die Listen nicht so häufig aktualisiere (1x pro 2 Monate der so).

Hatte dann mal den DHCP meiner PfSense umgestellt und die PfSense als DNs verteilt (Unbound). Wenn ich über die GUI, über DNS Lookup, Anfragen stelle habe ich über den konfigurierten IPv4 DNS teilweise über 5sek Antwortzeit. Manchmal sogar über 10sek!

Über IPv6 sind es idR so 6sek.

Getestet habe ich auch andere DNS-Server in der PfSense. Das Ergebnis bleibt gleich.

Dann mal am Linux über (das Ubuntu-Paket dnsutils) "dig @IP_des_dns ANZUFRAGENDE.SEITE" diverse DNS als auch immer neue Seiten getestet. Jedes mal das selbe Ergebnis: Manchmal kommt die Antwort des Terminals sofort, manchmal dauert die 5+ Sekunden. Allerdings wird mir die Anfrage fast immer <10msec beantwortet laut dig. Manchmal bekomme ich auch ne Fehlermeldung: "connection timed out; no servers could be reached". Vermutlich ist das CGN teilweise hoffnungslos überfordert und "cached" teilweise, bis es Daten ausliefern kann. Teilweise wird der "Cache" allerdings verworfen und Anfragen/Pakete somit nicht beantwortet/weitergeleitet.
Könnte mir da durchaus nen Zusammenhang zu deinem Problem vorstellen.

Hier ist 6RD konfiguriert und ich nutze laut myip.is 185.22.143.7 als NAT-Gateway.
Morgen will ich mal DHCPv6 als WAN konfigurieren (auch wenn mich das n Arsch voll Arbeit kostet) und das dann nochmal testen.

HS-Unterbruch -- Genexis Fibertwist
 Quote
19.12.2019, 17:43,
 
RE: Packetverluste
Das Ping Problem war bei mir aber bei normalen Paketen unabhängig von IPv4/IPv6 und war nach einigem Hin- und Her mit dem Support auf einmal verschwunden. Ich bin hier nicht im 6rd Gebiet. Normalerweise benutze ich die DNS von der DG nicht sondern habe auf einem vServer Bind laufen worauf ich über ein IPv6 VPN zugreife. Also zur Zeit läuft hier alles rund. Ist auch besser so denn sonst hat man leider bei unserem Anbieter erst mal ein Problem.
Traue mich kaum zu Fragen: mit anderer Router Hardware wie Laptop direkt am Fibertwist/Medienkonverter hast du auch schon getestet und den gleichen Effekt ? Wenn du die DNS Abfragen über IPv6 machst ist der CGN aus dem Spiel, ich kann mir vorstellen das auch die IPv4 DNS Server der DG Kundenseitig vor dem CGN sind

DGHome mit eigener Router Option
Übergabegerät DG: FiberTwist
virtueller Router (LXC Container) mit Openwrt 18.06.x auf einem Intel® Celeron® J4105 Board
Sip Telefon Abschluss auf Asterisk 13.x (LXC Container) auf gleichem Board
 Quote
19.12.2019, 18:06,
 
RE: Packetverluste
Gestern habe ich auf DHCPv6 statt 6RD umgestellt und auch diverse andere Dinge getan. Problem (welches bei mir keine Paketverluste sind, wie ich feststellen musste) sind hier aber gelöst.

Hab meinen PC direkt mal an den Fibertwist gepatched und die ganze Sache mal genauer angeschaut. Am PC waren keine Probleme aufgetreten. Die Firewall ist jetzt jedenfalls umgestellt, auch wenn einige Rechner hier im Netz, als auch mein VPN noch nicht wieder laufen. Noch zu wenig Zeit gehabt.
 Quote

  



Thread options
[-]
Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 2 Gast/Gäste